Author Topic: "43" response received - 99 Pontiac Grand AM  (Read 5879 times)

Anonymous

  • Guest
"43" response received - 99 Pontiac Grand AM
« on: May 28, 2003, 10:57:33 PM »
 Hi, I'm using a VPW Scantool card with ELM322 chip, when trying to 'read codes' I receive the error "43" response received but data has errors wrong number of bytes was received from ELM 32x device.  I've also tried Scantool.exe V1.06 and receive a "Bus error: OBDII bus is shorted to Vbatt or Ground".  I've connected the card to a 98 Chevrolet Silverado K3500 and everything seems to work fine.  Just can't seem to get the 99 Pontiac to read, any suggestions?  The OBDII connector on the 99 Pontiac has pins 2,4,5,9,16 populated, the 98 Chevrolet has pins 2,4,5,8,15,16 populated.  However the VPW scantool board only uses pins 2,5,16 on the OBDII connector.

Thanks in advance.

admin

  • Administrator
  • Member
  • *****
  • Posts: 54
    • View Profile
"43" response received - 99 Pontiac Grand AM
« Reply #1 on: May 29, 2003, 08:19:07 PM »
Try running RealScan using the /debug command switch.  The /debug command switch tells RealScan to log everything to a log file.  Select "read codes",  then exit out after it gives you the error.  The info gets logged to a file called obd.log.  Paste the results into the forum.  Then I'll take a look at the data and hopefully make some sense out of it.

Anonymous

  • Guest
"43" response received - 99 Pontiac Grand AM
« Reply #2 on: June 02, 2003, 09:53:39 PM »
 Hi, I did the /debug on the 1998 Chevrolet Silverado that seems to work ok and received the following obd.log file:

Response to "01 01" request is, "41010007E000

>"
Response to "03" request is, "41010007E000

>"
Final value in the troublecodes string is, "41010007E000

>"
Error/Info message is, "There are no troublecodes at this time."

Running the /debug on the 1999 Pontiac Grand AM SE gives the following obd.log file:

Response to "01 01" request is, "BUSERROR

>"
Response to "03" request is, "BUSERROR

>"
Final value in the troublecodes string is, "BUSERROR

>"
Error/Info message is, ""43" response received, but the data has error(s). Wrong number of bytes was received from the Elm 32x device."

admin

  • Administrator
  • Member
  • *****
  • Posts: 54
    • View Profile
"43" response received - 99 Pontiac Grand AM
« Reply #3 on: June 03, 2003, 01:02:54 AM »
 Definitely a hardware compatability problem.  For some reason my software is displaying the wrong error message.  I'll have to take a look at that.

One could take a multimeter and measure the voltage coming out of the voltage regulator on the circuit board, to make sure it's within reason.  On the ELM323 boards some have experimented with different transistors.  Not sure if that would help in this case.

Hopefully someone in the scantool.net forum will have a better answer for you.  If not, you could try contacting ELM Electronics.

admin

  • Administrator
  • Member
  • *****
  • Posts: 54
    • View Profile
"43" response received - 99 Pontiac Grand AM
« Reply #4 on: June 08, 2003, 12:03:19 AM »
 The "43 response received, but the data has error(s)." message that RealScan reported was due to a bug in RealScan .92's error handling.  It should have reported a "Bus Error" message.  All known error reporting bugs have been fixed in version .93